Support

When trying to activate soothe, I contantly get the error "Invalid user credentials for email ...". What is the issue? (legacy)

You are most likely trying to activate older version of the plug-in (1.0.7) with recently purchased license. The new licenses are automatically deployed to the new, more flexible license management of soothe, which requires soothe version 1.1.0 or newer.

If this is the case, please update to the most recent version. You can download it here.

Subscribe to our mailing list