Support

I redeemed/transferred my soothe license to my iLok account, but soothe doesn't find the activation

You’re probably seeing this prompt:

You are using an older version of soothe. iLok licenses are only supported in soothe 1.2.0 or later. Please uninstall 1.1.4 or earlier, and download the newest possible version of soothe from our downloads page. Also, please make sure that you have the latest iLok License Manager installed on your machine.

Subscribe to our mailing list